■BackWPupが有効化できない|重大なエラーを引き起こしたため、有効化できませんでした

BackWPupが有効化できない原因

WordPress(ワードプレス)を使っていて、バックアップを取るためにBackWPupをインストールしてその後、「有効化」しようとすると、

重大なエラーを引き起こしたため、プラグインを有効化できませんでした。
BackWPup requires PHP version 5.3 with spl extension or greater
and WordPress 3.9 or greater.

と出て有効化できないときの対処方法です。

日本語に翻訳すると、

BackWPupを使用するには、splバージョン以上のPHPバージョン5.3が必要です。
WordPress 3.9以上。

となります。

PHPのバージョンとWordPressnのバージョンが古いとダメということみたいです。



PHPをバージョンアップする方法(ロリポップ)

まずは、PHPのバージョンをアップさせる方法です。
PHPはサーバーの方で設定を変更する必要があります。

レンタルサーバにロリポップを使用している場合の説明をします。

ロリポップにログインし、ユーザー専用ページの
[サーバーの管理・設定]⇒[PHP設定]をクリックし開きます。

エラーの詳細に「PHPバージョン5.3以上が必要」とあったので、5.3以上のものを選びます。

選択が終われば[変更]をクリックします。

これで、PHPのバージョンアップは完了です。

WordPressワードプレスをバージョンアップする方法

次はWordpress(ワードプレス)をバージョンアップする方法です。

ダッシュボードの[更新]クリックします。

WordPress(ワードプレス)の更新情報があれば表示されるので、[今すぐ更新]をクリックします。

これでWordpress(ワードプレス)は更新できました。

BackWPup有効化をする

ダッシュボードの[プラグイン]⇒「インストール済みプラグイン」を開き

「BackWPup」の[有効化]をクリックします。

まとめ

これで、有効化できると思います。

また同じようにエラーが出る場合はしばらく時間をおいたり、再度ログインしなおしたりして試してみてください。

スポンサーリンク